Tommy Winther

twenty-first century code monkey

Opdatering til TV3 Play

TV3 Play er opdateret til version 1.0.2 og indeholder nu region valg som første menupunkt. Viasat4play.no er tilføjet som ny region efter Christoffer gjorde mig opmærksom på den – derudover er det også blevet muligt at se nyeste afsnit, mest sete afsnit, mv. for hver region.

 

Det er også blevet til en lille opdatering til Danish Live TV som indeholder en lille forbedring bag facaden. De TV2/Regioner som streamer via Fynske Medier vil nu bruge en streaming server med tilstrækkelig båndbredde frem for en med begrænset båndbredde.

29 Kommentarer

  1. TV3 Play kørte fint indtil for 3-4 dage siden. Nu kører startreklamen bare i ring, eller også køres der 3-4 reklameblokke og så meldes programmet set. Det gælder samtlige programmer på TV3 Play. Er vi de eneste der oplever det problem?

  2. Bjarke Thor Iversen

    18. maj 2012 at 19:13

    Hej.

    Har lige opgraderet til Eden, og kan ikke få danish live tv til at virke.
    De fleste gange fryser det hele efter et par minutter…. nogle tanker?

  3. Er det egentlig muligt at bruge viaplay.dk i XBMC, så hvis man har et login hvor man eks. kan se film, så kan det bruges i XBMC?

  4. Oplever det samme. Min status på denne plugin efter opdateringen er:

    TV3play.dk (ser kun reklamer)
    TV3play.se (ser kun reklamer)
    TV3play.no (virker)
    TV3play.lt (virker)
    TV3play.iv (virker ikke – fejlbesked om begrænsinger i rettigheder)
    Viasat4play.no (virker ikke – fejlbesked om begrænsinger i rettigheder)

    Blot til orientering, hvis det kunne få nogen på sporet af en løsning.

  5. Hej alle,
    I de har problemer med TV3 Play, kan i ikke skrive hvilke program og afsnit i prøver at afspille? Jeg har testet med et par stykker og det virker fint.
    Mht. rettighedsproblemet, så oplever jeg at nogle programmer er blokeret mens andre ikke er, så prøv jer frem.

    viaplay.dk er ikke muligt fordi de bruger silverlight, det kan XBMC ikke afspille, desværre.
    Mvh.
    Tommy

  6. For mit vedkommende har jeg efterhånden forsøgt flere afsnit fra alle programmer på tv3play.dk, og der sker det samme hvergang – der køres 3-4 reklamer og så markeres udsendelsen som set. Det samme er sket alle de gange jeg har forsøgt på tv3play.se. Til gengæld ser tv3play.no ud til at virke. Jeg er ikke stødt på problemet når jeg har forsøgt der.

    Som jeg husker det, opstod fejlen gradvist, så det kun skete for nogle afsnit i starten og dagen efter for resten. Jeg opdagede det da jeg så piratjagt i somalia hvor et filmhold følger besætningen på Absalon. Jeg kan ikke lige huske hvad programmet hedder.

    Jeg ved posetivt at jeg har forsøgt samtlige afsnit af de 5 første programmer på tv3paly.dks liste.

    Allan

  7. Hej Allan (og jer andre med problemet),
    Prøv og afspil et afsnit som giver problemer og send mig derefter jeres xbmc.log fil (fx via pastebin.com).
    Mvh.
    Tommy

  8. Steven Payne

    21. maj 2012 at 21:24

    Enig med Bergy… min viser også kun reklamer, og så ryger den tilbage til rod-menuen.

  9. Hej Tommy

    XBMC.log:

    http://pastebin.com/b3gL3Xsq

    Mvh

    Flemming

  10. Hej Tommy,

    Jeg er ret ny til det her, så jeg kan umiddelbart ikke finde ud af at lave dig en log-fil. Men hvis du skal bruge mere end den Flemming sendte dig, så vil jeg prøve at lave en.

  11. Tak Flemming, jeg kan se XBMC forsøger at afspille både reklamerne samt afsnittet, så addon’en opfører sig korrekt.

    Afspilning af afsnittet fejler som i skriver med:
    ERROR: RTMP_ReadPacket, failed to read RTMP packet header

    Det har jeg googlet lidt og det kan optræde hvis man bruger en alternativ DNS server, fx for at kunne tilgå udenlandsk indhold.
    Der er en tråd om det her:
    http://forum.xbmc.org/showthread.php?tid=131642

    Er det tilfælde for dig (jer andre?) at i bruger en alternativ DNS server?

    Mvh.
    Tommy

  12. Jeg har også haft problemer med TV3 play, og ja, jeg kører på en alternativ dns-server. Men det gør jeg også fra min mac, og der virker tv3 play helt fint… Hmm..?..

  13. Det tyder på problemet kun optræder på ATV2, hvis du læser tråden jeg linkede til: http://forum.xbmc.org/showthread.php?tid=131642
    Der er også noget med at opdatere librtmp nederst i tråden, så det er to ting at prøve:
    1) Skift tilbage til den almindelige DNS server og/eller 2) udskift librtmp.
    Mvh.
    Tommy

  14. Okay, jeg prøver lige at opdatere librtmp – men fatter ikke helt hvor jeg skal “enable” det henne – “After you’ve replaced librtmp, enable Updated libRTMP present in the settings of SuperTV and/or rtmpGUI+” – Fordi, der er da ikke SuperTV-indstillinger på ATV’et?

  15. Erstattede blot filen og det virker nu!

    Du er genial, Tommy 🙂

  16. Hej Jacob. Jeg kan se, at du muligvis har fundet en løsning, som er gangbar for os andre også. Kunne du skrive en kort beskrivelse af proceduren for, hvordan man udskifter librtmp?
    Hvor finder man den rigtige version, som virker? Og hvordan får man den udskiftet på atv???

  17. Hej Jacob. Fandt selv ud af at erstatte filen, men det giver ingen ændring på problemet her hos mig. Bruger nu version 2.4 af filen – er der en version nyere end det? Bruger dog også DNS (unblockUS), så det bliver det næste, jeg forsøger. Troede sørme lige, at vi var i mål :0

  18. Jeg erstattede filen, installerede SuperTV og genstartede XBMC. Herefter virkede det uden problemer. Og du har valgt den rigtige til iOS og ikke blot pc/mac osv.?

  19. Og jeg bruger også selv unblock, men har ikke ændret disse indstillinger da jeg bruger det konstant, så kan ikke undvære dem.

  20. Hej Tommy

    1000 tak for hjælpen. Den burde vi vist have fundet selv 🙂
    Anyway – lige lidt detaljer der muligvis kan hjælpe andre: Jeg bruger unblock-us.com af hensyn til netflix og BBC iPlayer. Denne service konflikter åbenbart med librtmp på iOS.

    Problemet løses ved at downloade librtmp til iOS fra http://supercloudtv.com/librtmp.html og overskrive den eksisterende version.
    Brug FileZilla eller CyberDuck – log på ATV2 som root og kopier librtmp.0.dylib til /Applications/XBMC.frappliance/Frameworks.

    Virker perfekt!

    mvh

    Flemming

  21. Tak for vejledningen. 5 min. på google og din vejledning gjorde det muligt for en newbie som mig at få det til at virke – selv om jeg ikke bruger alternativ DNS/unblock-us. At overskrive den eksisterende fil var alt hvad der skulle til.

  22. Fin beskrivelse, Flemming. Den er der sikkert mange der pt leder efter 🙂

    Bruger også Unblock, og til dem der er i tvivl; så er det ikke nødvendigt at ændre dns-serverne, hvis man bruger librmtp-løsningen.

  23. Super! Så lykkedes det sørme også for mig at få det op at køre igen. Tak til både Tommy og Flemming for denne løsning. Jeg er helt på linje med Alanp: Dette problem gør sig gældende både med og uden alternativ DNS – i hvert fald hjemme hos mig. Men nu kører det igen, super!

  24. Er ikke helt stiv i det her, ( Brug FileZilla eller CyberDuck – log på ATV2 som root og kopier librtmp.0.dylib til /Applications/XBMC.frappliance/Frameworks ) jeg har brugt putty er det ok ? jeg kan sagtens logge ind i root men hvordan kopierer jeg librtemp over ?
    Mvh.
    Michael

  25. Nu har jeg brugt cyberduck og kan sagtens komme ind i den rigtige mappe, men er i tvivl om det er selve zip filen der ligges ind i mappen eller om det er nogle af de udpakkede filer.

  26. Har løst problemet, havde hentet den forkerte fil ( Windows filen ) , beklager.
    Mvh.
    Michael

  27. Hej drenge…

    Jeg kan ikke se /Applications/XBMC.frappliance/Frameworks -> kun /Applications??

  28. /private/var/stash/Applications/XBMC.frappliance/Frameworks

    fungerer nu! 🙂

  29. Perfekt, TAK!

Der er lukket for kommentarer.

© 2019 Tommy Winther

Tema af Anders NorenOp ↑